aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-axes/django-axes-6.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-axes/django-axes-6.4.0.ebuild')
-rw-r--r--dev-python/django-axes/django-axes-6.4.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/django-axes/django-axes-6.4.0.ebuild b/dev-python/django-axes/django-axes-6.4.0.ebuild
new file mode 100644
index 0000000..c7a0507
--- /dev/null
+++ b/dev-python/django-axes/django-axes-6.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Keep track of failed login attempts in Django-powered sites"
+HOMEPAGE="
+ https://github.com/jazzband/django-axes
+ https://pypi.org/project/django-axes/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ doc? ( dev-python/sphinx-rtd-theme )"
+DEPEND="${RDEPEND}"
+
+# Tests depend on django-ipware, not packaged
+distutils_enable_sphinx docs