aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-axes/django-axes-6.4.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-05-25 13:46:45 -0400
committerJulien Roy <julien@jroy.ca>2024-05-25 13:46:45 -0400
commit9640e44d7a0940e49fdf2a5f47394ad698a6756f (patch)
tree95b0388709fc8a2295e9a609b82e0e80d3fc6aed /dev-python/django-axes/django-axes-6.4.0.ebuild
parent60990fe6c7a1f5ecd1cba3ba56ee96c8dfd81cb5 (diff)
downloadMrRoy-Overlay-9640e44d7a0940e49fdf2a5f47394ad698a6756f.tar.gz
MrRoy-Overlay-9640e44d7a0940e49fdf2a5f47394ad698a6756f.tar.bz2
MrRoy-Overlay-9640e44d7a0940e49fdf2a5f47394ad698a6756f.zip
dev-python/django-axes: new package, add 6.4.0
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/django-axes/django-axes-6.4.0.ebuild')
-rw-r--r--dev-python/django-axes/django-axes-6.4.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/django-axes/django-axes-6.4.0.ebuild b/dev-python/django-axes/django-axes-6.4.0.ebuild
new file mode 100644
index 0000000..c7a0507
--- /dev/null
+++ b/dev-python/django-axes/django-axes-6.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Keep track of failed login attempts in Django-powered sites"
+HOMEPAGE="
+ https://github.com/jazzband/django-axes
+ https://pypi.org/project/django-axes/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ doc? ( dev-python/sphinx-rtd-theme )"
+DEPEND="${RDEPEND}"
+
+# Tests depend on django-ipware, not packaged
+distutils_enable_sphinx docs