aboutsummaryrefslogtreecommitdiff
path: root/gui-wm/hyprland/hyprland-0.20.1.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-11 00:02:05 -0500
committerJulien Roy <julien@jroy.ca>2023-01-11 00:02:05 -0500
commit9a15474c78c84d63c419cb9bc138e9fd035005b1 (patch)
tree53351b3b8dec688f2011b0f6dec76160dd29f3f6 /gui-wm/hyprland/hyprland-0.20.1.ebuild
parent3820b13ea92cf773440d95730314939e8187a684 (diff)
downloadMrRoy-Overlay-9a15474c78c84d63c419cb9bc138e9fd035005b1.tar.gz
MrRoy-Overlay-9a15474c78c84d63c419cb9bc138e9fd035005b1.tar.bz2
MrRoy-Overlay-9a15474c78c84d63c419cb9bc138e9fd035005b1.zip
gui-wm/hyprland: add grimblast use flag
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'gui-wm/hyprland/hyprland-0.20.1.ebuild')
-rw-r--r--gui-wm/hyprland/hyprland-0.20.1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/gui-wm/hyprland/hyprland-0.20.1.ebuild b/gui-wm/hyprland/hyprland-0.20.1.ebuild
index d7c424b..45f8c6d 100644
--- a/gui-wm/hyprland/hyprland-0.20.1.ebuild
+++ b/gui-wm/hyprland/hyprland-0.20.1.ebuild
@@ -20,7 +20,7 @@ S="${WORKDIR}/Hyprland-${PV}beta"
KEYWORDS="~amd64"
LICENSE="BSD"
SLOT="0"
-IUSE="X grimblast shellevents systemd"
+IUSE="X grimblast systemd"
RDEPEND="
dev-libs/libevdev
@@ -59,7 +59,6 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
grimblast? ( app-text/scdoc )
- shellevents? ( app-text/scdoc )
"
src_unpack() {
@@ -84,3 +83,13 @@ src_configure() {
meson_src_configure
}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ meson_src_install
+
+ use grimblast && emake -C "${WORKDIR}/contrib-${CONTRIBCOMMIT}/grimblast" install
+}