aboutsummaryrefslogtreecommitdiff
path: root/gui-wm/hyprland/hyprland-0.20.1.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-10 23:45:27 -0500
committerJulien Roy <julien@jroy.ca>2023-01-10 23:45:27 -0500
commit3820b13ea92cf773440d95730314939e8187a684 (patch)
treeeeb62cf934f76acf4039e317402845f446cb1c3c /gui-wm/hyprland/hyprland-0.20.1.ebuild
parent3f8216aeedb9b08e159a6965824b69fe16f67379 (diff)
downloadMrRoy-Overlay-3820b13ea92cf773440d95730314939e8187a684.tar.gz
MrRoy-Overlay-3820b13ea92cf773440d95730314939e8187a684.tar.bz2
MrRoy-Overlay-3820b13ea92cf773440d95730314939e8187a684.zip
gui-wm/hyprland: use meson instead of cmake
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'gui-wm/hyprland/hyprland-0.20.1.ebuild')
-rw-r--r--gui-wm/hyprland/hyprland-0.20.1.ebuild55
1 files changed, 32 insertions, 23 deletions
diff --git a/gui-wm/hyprland/hyprland-0.20.1.ebuild b/gui-wm/hyprland/hyprland-0.20.1.ebuild
index d0f49a1..d7c424b 100644
--- a/gui-wm/hyprland/hyprland-0.20.1.ebuild
+++ b/gui-wm/hyprland/hyprland-0.20.1.ebuild
@@ -3,27 +3,24 @@
EAPI=8
-inherit cmake toolchain-funcs
+inherit meson toolchain-funcs
DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
HOMEPAGE="https://github.com/hyprwm/Hyprland/releases"
-if [[ "${PV}" == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hyprwm/Hyprland"
-else
- PROTOCOMMIT=301733ae466b229066ba15a53e6d8b91c5dcef5b
- WLRCOMMIT=dc7cc98cf21a8dc19ab8895505500e3700646af0
- SRC_URI="https://github.com/hyprwm/Hyprland/archive/v${PV}beta.tar.gz -> ${P}.tar.gz
- https://github.com/hyprwm/hyprland-protocols/archive/${PROTOCOMMIT}.tar.gz -> hyprland-protocols.tar.gz
- https://gitlab.freedesktop.org/wlroots/wlroots/-/archive/${WLRCOMMIT}/wlroots-${WLRCOMMIT}.tar.bz2 -> wlr.tar.bz2"
- KEYWORDS="~amd64"
- S="${WORKDIR}/Hyprland-${PV}beta"
-fi
+PROTOCOMMIT=301733ae466b229066ba15a53e6d8b91c5dcef5b
+WLRCOMMIT=dc7cc98cf21a8dc19ab8895505500e3700646af0
+CONTRIBCOMMIT=37c8121f98d76f57caa00dd7106877876e0d7483
+SRC_URI="https://github.com/hyprwm/Hyprland/archive/v${PV}beta.tar.gz -> ${P}.tar.gz
+ https://github.com/hyprwm/hyprland-protocols/archive/${PROTOCOMMIT}.tar.gz -> hyprland-protocols.tar.gz
+ https://github.com/hyprwm/contrib/archive/${CONTRIBCOMMIT}.tar.gz -> contrib.tar.gz
+ https://gitlab.freedesktop.org/wlroots/wlroots/-/archive/${WLRCOMMIT}/wlroots-${WLRCOMMIT}.tar.bz2 -> wlr.tar.bz2"
+S="${WORKDIR}/Hyprland-${PV}beta"
+KEYWORDS="~amd64"
LICENSE="BSD"
SLOT="0"
-IUSE="X systemd"
+IUSE="X grimblast shellevents systemd"
RDEPEND="
dev-libs/libevdev
@@ -45,6 +42,13 @@ RDEPEND="
x11-libs/libxkbcommon
x11-libs/pixman
virtual/libudev
+ grimblast? (
+ app-misc/jq
+ gui-apps/grim
+ gui-apps/slurp
+ gui-apps/wl-clipboard
+ x11-libs/libnotify
+ )
X? (
x11-base/xwayland
x11-libs/libxcb
@@ -53,16 +57,18 @@ RDEPEND="
)
"
DEPEND="${RDEPEND}"
+BDEPEND="
+ grimblast? ( app-text/scdoc )
+ shellevents? ( app-text/scdoc )
+"
src_unpack() {
default
- if [[ "${PV}" != *9999* ]]; then
- rmdir "${S}/subprojects/wlroots"
- rmdir "${S}/subprojects/hyprland-protocols"
- mv "${WORKDIR}/wlroots-${WLRCOMMIT}" "${S}/subprojects/wlroots" || die
- mv "${WORKDIR}/hyprland-protocols-${PROTOCOMMIT}" "${S}/subprojects/hyprland-protocols" || die
- fi
+ rmdir "${S}/subprojects/wlroots"
+ rmdir "${S}/subprojects/hyprland-protocols"
+ mv "${WORKDIR}/wlroots-${WLRCOMMIT}" "${S}/subprojects/wlroots" || die
+ mv "${WORKDIR}/hyprland-protocols-${PROTOCOMMIT}" "${S}/subprojects/hyprland-protocols" || die
}
src_configure() {
@@ -71,7 +77,10 @@ src_configure() {
die "Hyprland requires >=sys-devel/gcc-12.1.0 or >=sys-devel/clang-15.0.0 to build"
fi
- mycmakeargs+=( -DNO_XWAYLAND:STRING=$(usex X false true) )
- mycmakeargs+=( -DNO_SYSTEMD:STRING=$(usex systemd false true) )
- cmake_src_configure
+ local emesonargs=(
+ $(meson_feature X xwayland)
+ $(meson_feature systemd)
+ )
+
+ meson_src_configure
}