aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-dottedname/zope-dottedname-5.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-02-04 21:04:57 -0500
committerJulien Roy <julien@jroy.ca>2023-02-04 21:04:57 -0500
commit631a280c2b2a79905facf113d50a7a24f57d7dfd (patch)
treeed80914f9f2a51184f6fede586a3ac348a5cc6d1 /dev-python/zope-dottedname/zope-dottedname-5.0.ebuild
parent4ed870ae8334375b375045841de8042b09b6032a (diff)
downloadMrRoy-Overlay-631a280c2b2a79905facf113d50a7a24f57d7dfd.tar.gz
MrRoy-Overlay-631a280c2b2a79905facf113d50a7a24f57d7dfd.tar.bz2
MrRoy-Overlay-631a280c2b2a79905facf113d50a7a24f57d7dfd.zip
dev-python/zope-dottedname: new package, add 5.0
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/zope-dottedname/zope-dottedname-5.0.ebuild')
-rw-r--r--dev-python/zope-dottedname/zope-dottedname-5.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/zope-dottedname/zope-dottedname-5.0.ebuild b/dev-python/zope-dottedname/zope-dottedname-5.0.ebuild
new file mode 100644
index 0000000..8b6b75f
--- /dev/null
+++ b/dev-python/zope-dottedname/zope-dottedname-5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Resolve strings containing dotted names into the appropriate python object"
+HOMEPAGE="https://github.com/zopefoundation/zope.dottedname"
+SRC_URI="https://github.com/zopefoundation/zope.dottedname/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN/-/\.}-${PV}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_test() {
+ cd "${S}/src/zope/dottedname" || die
+ distutils-r1_src_test
+}