aboutsummaryrefslogtreecommitdiff
path: root/app-portage/puppy/puppy-9999.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-05-19 13:09:06 -0400
committerJulien Roy <julien@jroy.ca>2024-05-19 13:09:06 -0400
commit237d45ac15f77fc2dc241e0e286b03c951649da8 (patch)
tree9f9722dec36ccab165685a462524e5a3e0e49658 /app-portage/puppy/puppy-9999.ebuild
parent44cb72b751650a1d565052dfd6b814e725f9d867 (diff)
downloadMrRoy-Overlay-237d45ac15f77fc2dc241e0e286b03c951649da8.tar.gz
MrRoy-Overlay-237d45ac15f77fc2dc241e0e286b03c951649da8.tar.bz2
MrRoy-Overlay-237d45ac15f77fc2dc241e0e286b03c951649da8.zip
app-portage/puppy: new package, add 9999
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'app-portage/puppy/puppy-9999.ebuild')
-rw-r--r--app-portage/puppy/puppy-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-portage/puppy/puppy-9999.ebuild b/app-portage/puppy/puppy-9999.ebuild
new file mode 100644
index 0000000..182b948
--- /dev/null
+++ b/app-portage/puppy/puppy-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit python-single-r1
+
+DESCRIPTION="Utility for compiling packages on remote hosts using Portage"
+HOMEPAGE="https://gitlab.com/doasu/puppy"
+
+if [[ ${PV} == 9999 ]]; then
+ # Use my fork for now
+ EGIT_REPO_URI="https://gitlab.com/MrRoy3/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.com/doasu/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+client +server"
+REQUIRED_USE="
+ || ( client server )
+ ${PYTHON_REQUIRED_USE}
+"
+
+RDEPEND="
+ sys-apps/portage
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ python_domodule server_request.py
+
+ if use server; then
+ python_doscript portage_server.py
+ fi
+
+ if use client; then
+ python_doscript pup.py
+ fi
+}