aboutsummaryrefslogtreecommitdiff
path: root/dev-python/rest-framework-generic-relations/rest-framework-generic-relations-2.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rest-framework-generic-relations/rest-framework-generic-relations-2.2.0.ebuild')
-rw-r--r--dev-python/rest-framework-generic-relations/rest-framework-generic-relations-2.2.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/rest-framework-generic-relations/rest-framework-generic-relations-2.2.0.ebuild b/dev-python/rest-framework-generic-relations/rest-framework-generic-relations-2.2.0.ebuild
new file mode 100644
index 0000000..28c1d59
--- /dev/null
+++ b/dev-python/rest-framework-generic-relations/rest-framework-generic-relations-2.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+# Release 2.2.0 isn't tagged by upstream
+COMMIT="35e7d5525c8957659f528fc45c73ad16949018c6"
+DESCRIPTION="Django REST Framework serializers to handle generic foreign keys"
+HOMEPAGE="
+ https://github.com/craigds/rest-framework-generic-relations
+ https://pypi.org/project/rest-framework-generic-relations/
+"
+# PyPI release doesn't package tests properly
+SRC_URI="https://github.com/craigds/rest-framework-generic-relations/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/djangorestframework-3.11.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --ds=testsettings
+}