aboutsummaryrefslogtreecommitdiff
path: root/dev-python/drf-spectacular/drf-spectacular-0.27.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/drf-spectacular/drf-spectacular-0.27.2.ebuild')
-rw-r--r--dev-python/drf-spectacular/drf-spectacular-0.27.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/drf-spectacular/drf-spectacular-0.27.2.ebuild b/dev-python/drf-spectacular/drf-spectacular-0.27.2.ebuild
new file mode 100644
index 0000000..7e838a1
--- /dev/null
+++ b/dev-python/drf-spectacular/drf-spectacular-0.27.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sane and flexible OpenAPI 3 schema generation for Django REST framework"
+HOMEPAGE="
+ https://github.com/tfranzel/drf-spectacular
+ https://pypi.org/project/drf-spectacular/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+# Can't get django tests run
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/django-allauth[${PYTHON_USEDEP}]
+ >=dev-python/django-filter-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/djangorestframework-3.10.3[${PYTHON_USEDEP}]
+ >=dev-python/djangorestframework-simplejwt-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/dj-rest-auth-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/inflection-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.3.2[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2[${PYTHON_USEDEP}]
+ <dev-python/pydantic-3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/twine-3.1.1[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-2.0.0[${PYTHON_USEDEP}]
+
+ doc? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
+ )
+ test? ( >=dev-python/pytest-django-3.8.0[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs