aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-simple-history/django-simple-history-3.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-simple-history/django-simple-history-3.7.0.ebuild')
-rw-r--r--dev-python/django-simple-history/django-simple-history-3.7.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/django-simple-history/django-simple-history-3.7.0.ebuild b/dev-python/django-simple-history/django-simple-history-3.7.0.ebuild
new file mode 100644
index 0000000..25ed6f5
--- /dev/null
+++ b/dev-python/django-simple-history/django-simple-history-3.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Store model history and view/revert changes from admin site"
+HOMEPAGE="
+ https://github.com/jazzband/django-simple-history
+ https://pypi.org/project/django-simple-history/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+# Tests fail to run
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/mysqlclient[${PYTHON_USEDEP}]
+
+ test? ( dev-python/asgiref[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests setup.py