aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-activity-stream/django-activity-stream-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-activity-stream/django-activity-stream-2.0.0.ebuild')
-rw-r--r--dev-python/django-activity-stream/django-activity-stream-2.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/django-activity-stream/django-activity-stream-2.0.0.ebuild b/dev-python/django-activity-stream/django-activity-stream-2.0.0.ebuild
new file mode 100644
index 0000000..f9be024
--- /dev/null
+++ b/dev-python/django-activity-stream/django-activity-stream-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Generate generic activity streams from the actions on your site"
+HOMEPAGE="
+ https://pypi.org/project/django-activity-stream
+ https://github.com/justquick/django-activity-stream
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+# Can't get django tests to run
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+ >=dev-python/django-mysql-2.4.1[${PYTHON_USEDEP}]
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/drf-spectacular[${PYTHON_USEDEP}]
+ >=dev-python/mysqlclient-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.8.0[${PYTHON_USEDEP}]
+ dev-python/rest-framework-generic-relations
+
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest