aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-11-23 13:27:26 -0500
committerJulien Roy <julien@jroy.ca>2024-11-23 13:27:26 -0500
commitafd71b46f9b782f5f768ca859321f4a590ad0616 (patch)
treeeab95d53de2d324529970310b812407587255ea8 /dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild
parent0537298d62260dd5928fe564f4c67aa7bbb98278 (diff)
downloadwger-overlay-afd71b46f9b782f5f768ca859321f4a590ad0616.tar.gz
wger-overlay-afd71b46f9b782f5f768ca859321f4a590ad0616.tar.bz2
wger-overlay-afd71b46f9b782f5f768ca859321f4a590ad0616.zip
dev-python/django-recaptcha: new package, add 4.0.0
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild')
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild b/dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild
new file mode 100644
index 0000000..1a3260c
--- /dev/null
+++ b/dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django reCAPTCHA form field/widget integration app"
+HOMEPAGE="
+ https://github.com/django-recaptcha/django-recaptcha
+ https://pypi.org/project/django-recaptcha/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+# Can't get django tests to run
+RESTRICT="test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest