aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-axes/django-axes-7.0.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-11-23 12:37:08 -0500
committerJulien Roy <julien@jroy.ca>2024-11-23 12:37:08 -0500
commit1f312856e54bb3b32f67d2372c822d876d8117c9 (patch)
tree583c8546574cba3f2a866ab00330b2dc2a0ef841 /dev-python/django-axes/django-axes-7.0.0.ebuild
parentc12e4e158b55450d4b0bc33a22799601450da67e (diff)
downloadwger-overlay-1f312856e54bb3b32f67d2372c822d876d8117c9.tar.gz
wger-overlay-1f312856e54bb3b32f67d2372c822d876d8117c9.tar.bz2
wger-overlay-1f312856e54bb3b32f67d2372c822d876d8117c9.zip
dev-python/django-axes: new package, add 7.0.0
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/django-axes/django-axes-7.0.0.ebuild')
-rw-r--r--dev-python/django-axes/django-axes-7.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/django-axes/django-axes-7.0.0.ebuild b/dev-python/django-axes/django-axes-7.0.0.ebuild
new file mode 100644
index 0000000..d84b01d
--- /dev/null
+++ b/dev-python/django-axes/django-axes-7.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Keep track of failed login attempts in Django-powered sites"
+HOMEPAGE="
+ https://github.com/jazzband/django-axes
+ https://pypi.org/project/django-axes/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ doc? ( dev-python/sphinx-rtd-theme )"
+DEPEND="${RDEPEND}"
+
+# Tests depend on django-ipware, not packaged
+distutils_enable_sphinx docs