aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-allauth/django-allauth-65.2.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-11-23 01:02:25 -0500
committerJulien Roy <julien@jroy.ca>2024-11-23 01:14:50 -0500
commit9199232cc928ca045311dfcb19cd272c30b03666 (patch)
tree813f2a841fab7bc09ef4885999144ac9e5d840eb /dev-python/django-allauth/django-allauth-65.2.0.ebuild
parentbbd5b26aa10694abd8760ad89acdff6227f4e1de (diff)
downloadwger-overlay-9199232cc928ca045311dfcb19cd272c30b03666.tar.gz
wger-overlay-9199232cc928ca045311dfcb19cd272c30b03666.tar.bz2
wger-overlay-9199232cc928ca045311dfcb19cd272c30b03666.zip
dev-python/django-allauth: new package, add 65.2.0
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/django-allauth/django-allauth-65.2.0.ebuild')
-rw-r--r--dev-python/django-allauth/django-allauth-65.2.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/django-allauth/django-allauth-65.2.0.ebuild b/dev-python/django-allauth/django-allauth-65.2.0.ebuild
new file mode 100644
index 0000000..3f2dff7
--- /dev/null
+++ b/dev-python/django-allauth/django-allauth-65.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django applications addressing authentication, registration, account management"
+HOMEPAGE="
+ https://allauth.org/
+ https://github.com/pennersr/django-allauth
+ https://pypi.org/project/django-allauth/
+"
+SRC_URI="https://github.com/pennersr/django-allauth/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/asgiref-3.8.1[${PYTHON_USEDEP}]
+ >=dev-python/django-4.2.16[${PYTHON_USEDEP}]
+ >=dev-python/fido2-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/qrcode-7.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python3-openid-3.0.8[${PYTHON_USEDEP}]
+ >=dev-python/python3-saml-1.15.0[${PYTHON_USEDEP}]
+ <dev-python/python3-saml-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.3.0[${PYTHON_USEDEP}]
+
+ test? (
+ >=dev-python/pillow-9.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.23.8[${PYTHON_USEDEP}]
+ >=dev-python/pytest-django-4.5.2[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Deselect network tests
+ allauth/socialaccount/providers/openid/tests.py::OpenIDTests::test_login
+ allauth/socialaccount/providers/openid/tests.py::OpenIDTests::test_login_with_extra_attributes
+)