aboutsummaryrefslogtreecommitdiff
path: root/www-apps/searx/searx-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/searx/searx-1.1.0.ebuild')
-rw-r--r--www-apps/searx/searx-1.1.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/www-apps/searx/searx-1.1.0.ebuild b/www-apps/searx/searx-1.1.0.ebuild
new file mode 100644
index 0000000..368c5ad
--- /dev/null
+++ b/www-apps/searx/searx-1.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Privacy-respecting metasearch engine"
+HOMEPAGE="https://github.com/searx/searx"
+SRC_URI="https://github.com/searx/searx/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-arch/brotli[python]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-babel[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/langdetect[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ doc? (
+ app-text/linuxdoc-tools
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pallets-sphinx-themes[${PYTHON_USEDEP}]
+ dev-python/sphinx-issues[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-programoutput[${PYTHON_USEDEP}]
+ dev-python/splinter[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/cov-core[${PYTHON_USEDEP}]
+ app-i18n/transifex-client
+ dev-python/twine[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests nose