aboutsummaryrefslogtreecommitdiff
path: root/www-apps/meta-srht/meta-srht-0.54.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/meta-srht/meta-srht-0.54.4.ebuild')
-rw-r--r--www-apps/meta-srht/meta-srht-0.54.4.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/www-apps/meta-srht/meta-srht-0.54.4.ebuild b/www-apps/meta-srht/meta-srht-0.54.4.ebuild
index 48a2220..ae168a6 100644
--- a/www-apps/meta-srht/meta-srht-0.54.4.ebuild
+++ b/www-apps/meta-srht/meta-srht-0.54.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
DISTUTILS_USE_PEP517=setuptools
@@ -46,6 +46,13 @@ src_compile() {
ego build -o metasrht-api
}
+src_install() {
+ distutils-r1_src_install
+ dobin "${S}/api/metasrht-api"
+ insinto "/etc/"
+ newins "${S}/config.example.ini"
+}
+
plg_postinst() {
optfeature "billing support" "dev-python/stripe dev-python/weasyprint"
}