aboutsummaryrefslogtreecommitdiff
path: root/net-im/mautrix-telegram/mautrix-telegram-0.12.2_p20230118.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/mautrix-telegram/mautrix-telegram-0.12.2_p20230118.ebuild')
-rw-r--r--net-im/mautrix-telegram/mautrix-telegram-0.12.2_p20230118.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/net-im/mautrix-telegram/mautrix-telegram-0.12.2_p20230118.ebuild b/net-im/mautrix-telegram/mautrix-telegram-0.12.2_p20230118.ebuild
index 90a8db4..bb6e757 100644
--- a/net-im/mautrix-telegram/mautrix-telegram-0.12.2_p20230118.ebuild
+++ b/net-im/mautrix-telegram/mautrix-telegram-0.12.2_p20230118.ebuild
@@ -60,18 +60,22 @@ src_install() {
}
pkg_postinst() {
+ optfeature "Prometheus statistics" dev-python/prometheus_client
+ optfeature "Sqlite backend" dev-python/aiosqlite
+
einfo
- elog "Before you can use ${PN}, you must configure it correctly."
+ elog ""
+ elog "Before you can use ${PN}, you must configure it correctly"
elog "The configuration file is located at \"/etc/mautrix/${PN/-/_}.yaml\""
- elog "Next, you must generate a registration file using the following command"
- elog "sudo -u ${PN} /usr/bin/python -m ${PN/-/_} -c /etc/mautrix/${PN}.yaml g"
- elog "Next, you must register you registration.yaml file with your homeserver"
- elog "Then you must launch ${PN} by specifying the registration file"
- elog "sudo -u ${PN} /usr/bin/python -m ${PN/-/_} -r registration.yaml"
- elog "After this you can register the bridge with your homeserver"
- elog "Finally, you can start the ${PN} daemon"
+ elog "When done, run the following command: emerge --config ${PN}"
+ elog "Then, you must register the bridge with your homeserver"
+ elog "Refer your homeserver's documentation for instructions"
+ elog "The registration file is located at /var/lib/${PN/-/\/}/registration.yaml"
+ elog "Finally, you may start the ${PN} daemon"
einfo
+}
- optfeature "Prometheus statistics" dev-python/prometheus_client
- optfeature "Sqlite backend" dev-python/aiosqlite
+pkg_config() {
+ su - "${PN}" -s /bin/sh -c \
+ "/usr/bin/python -m \"${PN/-/_}\" -c \"/etc/mautrix/${PN}.yaml -g /var/lib/${PN/-/\/}/registration.yaml\""
}