aboutsummaryrefslogtreecommitdiff
path: root/mail-client/tutanota/tutanota-3.94.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/tutanota/tutanota-3.94.9.ebuild')
-rw-r--r--mail-client/tutanota/tutanota-3.94.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/mail-client/tutanota/tutanota-3.94.9.ebuild b/mail-client/tutanota/tutanota-3.94.9.ebuild
new file mode 100644
index 0000000..c92fd3a
--- /dev/null
+++ b/mail-client/tutanota/tutanota-3.94.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tutanota is an email service with a strong focus on security and privacy"
+HOMEPAGE="https://tutanota.com/"
+SRC_URI="https://github.com/tutao/${PN}/archive/${PN}-release-${PV}-unpacked-linux.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=net-libs/nodejs-14.0.0[npm]"
+RDEPEND="${DEPEND}
+ app-crypt/libsecret"
+BDEPEND=""
+
+S=${WORKDIR}/${PN}-${PN}-release-${PV}
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ export NODE_ENV="production"
+ npm ci
+ default
+}
+
+src_compile() {
+ npm run build-packages
+}
+
+src_install() {
+ node desktop --custom-desktop-release
+}