aboutsummaryrefslogtreecommitdiff
path: root/gui-wm/newm/newm-0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-wm/newm/newm-0.3.ebuild')
-rw-r--r--gui-wm/newm/newm-0.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/gui-wm/newm/newm-0.3.ebuild b/gui-wm/newm/newm-0.3.ebuild
new file mode 100644
index 0000000..0455580
--- /dev/null
+++ b/gui-wm/newm/newm-0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland compositor written with laptops and touchpads in mind"
+HOMEPAGE="https://github.com/jbuchermn/newm"
+SRC_URI="https://github.com/jbuchermn/newm/archive/refs/tags/v${PV}alpha.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="custom_renderer xwayland"
+
+DEPEND="dev-python/dasbus
+ dev-python/psutil
+ dev-python/pyfiglet
+ dev-python/python-pam
+ dev-python/pycairo
+ dev-python/pywm
+ dev-python/thefuzz
+ gui-libs/wlroots"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure(){
+ local emesonargs=(
+ $(meson_feature custom_renderer)
+ $(meson_feature xwayland)
+ )
+ meson_src_configure
+}