aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-traversing/zope-traversing-4.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-traversing/zope-traversing-4.4.1.ebuild')
-rw-r--r--dev-python/zope-traversing/zope-traversing-4.4.1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/zope-traversing/zope-traversing-4.4.1.ebuild b/dev-python/zope-traversing/zope-traversing-4.4.1.ebuild
index 087e459..0b24e20 100644
--- a/dev-python/zope-traversing/zope-traversing-4.4.1.ebuild
+++ b/dev-python/zope-traversing/zope-traversing-4.4.1.ebuild
@@ -55,6 +55,13 @@ python_compile() {
find "${BUILD_DIR}" -name '*.pth' -delete || die
}
+python_compile_all() {
+ echo "__path__ = __import__('pkgutil').extend_path(__path__, __name__)" > \
+ "${BUILD_DIR}/install$(python_get_sitedir)/zope/__init__.py" || die
+ build_sphinx docs
+ rm "${BUILD_DIR}/install$(python_get_sitedir)/zope/__init__.py"
+}
+
src_test() {
cd "${S}/src/zope/untrustedpython" || die
distutils-r1_src_test