aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-size/zope-size-4.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-size/zope-size-4.4.ebuild')
-rw-r--r--dev-python/zope-size/zope-size-4.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/zope-size/zope-size-4.4.ebuild b/dev-python/zope-size/zope-size-4.4.ebuild
new file mode 100644
index 0000000..6144003
--- /dev/null
+++ b/dev-python/zope-size/zope-size-4.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple interface and default adapter for retrieving the size of an object"
+HOMEPAGE="https://github.com/zopefoundation/zope.size"
+SRC_URI="https://github.com/zopefoundation/zope.size/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN/-/\.}-${PV}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+# Zope Testrunner
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-configuration[${PYTHON_USEDEP}]
+ dev-python/zope-security[${PYTHON_USEDEP}]
+ doc? ( dev-python/repoze-sphinx-autointerface[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_test() {
+ cd "${S}/src/zope/untrustedpython" || die
+ distutils-r1_src_test
+}