aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-location/zope-location-4.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-location/zope-location-4.3.ebuild')
-rw-r--r--dev-python/zope-location/zope-location-4.3.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/zope-location/zope-location-4.3.ebuild b/dev-python/zope-location/zope-location-4.3.ebuild
index 7fe42da..dc2e5d9 100644
--- a/dev-python/zope-location/zope-location-4.3.ebuild
+++ b/dev-python/zope-location/zope-location-4.3.ebuild
@@ -32,7 +32,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
distutils_enable_sphinx docs
-distutils_enable_tests unittest
+distutils_enable_tests setup.py
src_prepare() {
# strip rdep specific to namespaces
@@ -45,7 +45,8 @@ python_compile() {
find "${BUILD_DIR}" -name '*.pth' -delete || die
}
-src_test(){
- cd "${S}/src/zope/location" || die
- distutils-r1_src_test
+python_test() {
+ distutils_write_namespace zope
+ zope-testrunner -pvc -j "$(nproc)" --usecompiled \
+ --path "${BUILD_DIR}/install$(python_get_sitedir)/zope" || die
}