aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-app-wsgi/zope-app-wsgi-5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-app-wsgi/zope-app-wsgi-5.0.ebuild')
-rw-r--r--dev-python/zope-app-wsgi/zope-app-wsgi-5.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/zope-app-wsgi/zope-app-wsgi-5.0.ebuild b/dev-python/zope-app-wsgi/zope-app-wsgi-5.0.ebuild
new file mode 100644
index 0000000..6e41018
--- /dev/null
+++ b/dev-python/zope-app-wsgi/zope-app-wsgi-5.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="WSGI application for the zope.publisher package"
+HOMEPAGE="https://github.com/zopefoundation/zope.app.wsgi"
+SRC_URI="https://github.com/zopefoundation/zope.app.wsgi/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/zope.app.wsgi-${PV}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+# Zope Testrunner
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/transaction[${PYTHON_USEDEP}]
+ dev-python/zconfig[${PYTHON_USEDEP}]
+ dev-python/zope-app-appsetup[${PYTHON_USEDEP}]
+ dev-python/zope-app-publication[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-container[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/zope-processlifetime[${PYTHON_USEDEP}]
+ dev-python/zope-publisher[${PYTHON_USEDEP}]
+ dev-python/zope-security[${PYTHON_USEDEP}]
+ dev-python/zope-site[${PYTHON_USEDEP}]
+ dev-python/zope-traversing[${PYTHON_USEDEP}]
+ test? (
+ dev-python/webtest[${PYTHON_USEDEP}]
+ dev-python/zope-authentication[${PYTHON_USEDEP}]
+ dev-python/zope-browserpage[${PYTHON_USEDEP}]
+ dev-python/zope-principalregistry[${PYTHON_USEDEP}]
+ dev-python/zope-securitypolicy[${PYTHON_USEDEP}]
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ dev-python/zope-testrunner[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}