aboutsummaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-zopeext/sphinxcontrib-zopeext-0.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-zopeext/sphinxcontrib-zopeext-0.3.3.ebuild')
-rw-r--r--dev-python/sphinxcontrib-zopeext/sphinxcontrib-zopeext-0.3.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-zopeext/sphinxcontrib-zopeext-0.3.3.ebuild b/dev-python/sphinxcontrib-zopeext/sphinxcontrib-zopeext-0.3.3.ebuild
new file mode 100644
index 0000000..eaaaac7
--- /dev/null
+++ b/dev-python/sphinxcontrib-zopeext/sphinxcontrib-zopeext-0.3.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension for using Zope interfaces"
+HOMEPAGE="https://github.com/sphinx-contrib/zopeext"
+SRC_URI="https://github.com/sphinx-contrib/zopeext/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/zopeext-${PV}"
+# Tests won't even run
+RESTRICT="test"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/sphinx-testing[${PYTHON_USEDEP}]' python3_{9,10})
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest