aboutsummaryrefslogtreecommitdiff
path: root/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-1.0.0.ebuild')
-rw-r--r--dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-1.0.0.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-1.0.0.ebuild b/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-1.0.0.ebuild
deleted file mode 100644
index 368934d..0000000
--- a/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-1.0.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Auto-generate Sphinx API docs from Zope interfaces"
-HOMEPAGE="https://github.com/repoze/repoze.sphinx.autointerface/"
-SRC_URI="https://github.com/repoze/repoze.sphinx.autointerface/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/repoze.sphinx.autointerface-${PV}"
-
-LICENSE="BSD-with-disclosure"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/zope-interface[${PYTHON_USEDEP}]
- test? ( dev-python/zope-testrunner[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests setup.py
-
-python_test() {
- distutils_write_namespace zope
- zope-testrunner -pvc -j "$(nproc)" --usecompiled \
- --path "${BUILD_DIR}/install$(python_get_sitedir)/zope" || die
-}