aboutsummaryrefslogtreecommitdiff
path: root/dev-python/python3-openid/python3-openid-3.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python3-openid/python3-openid-3.2.0.ebuild')
-rw-r--r--dev-python/python3-openid/python3-openid-3.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python3-openid/python3-openid-3.2.0.ebuild b/dev-python/python3-openid/python3-openid-3.2.0.ebuild
new file mode 100644
index 0000000..b0fa50a
--- /dev/null
+++ b/dev-python/python3-openid/python3-openid-3.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python 3 port of the python-openid library"
+HOMEPAGE="
+ https://github.com/necaris/python3-openid
+ https://pypi.org/project/python3-openid/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+# Can't get tests to run
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/mysqlclient[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/psycopg2cffi[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest