aboutsummaryrefslogtreecommitdiff
path: root/dev-python/python-srht/python-srht-0.65.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-srht/python-srht-0.65.8.ebuild')
-rw-r--r--dev-python/python-srht/python-srht-0.65.8.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/python-srht/python-srht-0.65.8.ebuild b/dev-python/python-srht/python-srht-0.65.8.ebuild
deleted file mode 100644
index 6a96a7a..0000000
--- a/dev-python/python-srht/python-srht-0.65.8.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-PB="core.sr.ht"
-BOOTSTRAPVER="4.1.1"
-DESCRIPTION="sr.ht shared code"
-HOMEPAGE="https://git.sr.ht/~sircmpwn/core.sr.ht"
-SRC_URI="http://git.sr.ht/~sircmpwn/${PB}/archive/${PV}.tar.gz -> ${PB}.tar.gz
- https://github.com/twbs/bootstrap/archive/v${BOOTSTRAPVER}.tar.gz -> bootstrap.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-#KEYWORDS="~amd64"
-RESTRICT="network-sandbox"
-
-RDEPEND="dev-python/alembic[${PYTHON_USEDEP}]
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/bleach[${PYTHON_USEDEP}]
- dev-python/celery[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/humanize[${PYTHON_USEDEP}]
- dev-python/mistletoe[${PYTHON_USEDEP}]
- dev-python/PGPy[${PYTHON_USEDEP}]
- dev-python/prometheus_client[${PYTHON_USEDEP}]
- dev-python/psycopg:2[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/SQLAlchemy-Utils[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="net-libs/nodejs"
-
-S="${WORKDIR}/${PB}-${PV}"
-src_unpack() {
- default
- mv "${WORKDIR}/bootstrap-${BOOTSTRAPVER}" "${WORKDIR}/bootstrap" || die
- cp -r "${WORKDIR}/bootstrap" "${S}/srht/scss" || die
-}