aboutsummaryrefslogtreecommitdiff
path: root/dev-python/portion/portion-2.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/portion/portion-2.3.0.ebuild')
-rw-r--r--dev-python/portion/portion-2.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/portion/portion-2.3.0.ebuild b/dev-python/portion/portion-2.3.0.ebuild
new file mode 100644
index 0000000..e101a17
--- /dev/null
+++ b/dev-python/portion/portion-2.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A Python library providing data structure and operations for intervals."
+HOMEPAGE="https://github.com/AlexandreDecan/portion"
+SRC_URI="https://github.com/AlexandreDecan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/black[${PYTHON_USEDEP}]
+)"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/sortedcontainers"
+
+distutils_enable_tests pytest