aboutsummaryrefslogtreecommitdiff
path: root/dev-python/portion/portion-2.3.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2022-12-22 19:52:45 -0500
committerJulien Roy <julien@jroy.ca>2022-12-22 19:52:45 -0500
commit9ecfefa8427397bfd74fb47fafaa34a7e19c3c5b (patch)
tree3ad5a92ee7775eb54d9f21635bf4849079a7e35f /dev-python/portion/portion-2.3.0.ebuild
parent1004b951519cbba0d41412a2d8dd076a126deee5 (diff)
downloadMrRoy-Overlay-9ecfefa8427397bfd74fb47fafaa34a7e19c3c5b.tar.gz
MrRoy-Overlay-9ecfefa8427397bfd74fb47fafaa34a7e19c3c5b.tar.bz2
MrRoy-Overlay-9ecfefa8427397bfd74fb47fafaa34a7e19c3c5b.zip
dev-python/portion: new package, add 2.3.0
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/portion/portion-2.3.0.ebuild')
-rw-r--r--dev-python/portion/portion-2.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/portion/portion-2.3.0.ebuild b/dev-python/portion/portion-2.3.0.ebuild
new file mode 100644
index 0000000..e101a17
--- /dev/null
+++ b/dev-python/portion/portion-2.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A Python library providing data structure and operations for intervals."
+HOMEPAGE="https://github.com/AlexandreDecan/portion"
+SRC_URI="https://github.com/AlexandreDecan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/black[${PYTHON_USEDEP}]
+)"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/sortedcontainers"
+
+distutils_enable_tests pytest