aboutsummaryrefslogtreecommitdiff
path: root/dev-python/multipart/multipart-0.2.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/multipart/multipart-0.2.4.ebuild')
-rw-r--r--dev-python/multipart/multipart-0.2.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/multipart/multipart-0.2.4.ebuild b/dev-python/multipart/multipart-0.2.4.ebuild
new file mode 100644
index 0000000..a9c97cc
--- /dev/null
+++ b/dev-python/multipart/multipart-0.2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Multipart parser for Python 3"
+HOMEPAGE="https://github.com/defnull/multipart"
+SRC_URI="https://github.com/defnull/multipart/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ "${FILESDIR}/multipart-urlencoded-test.patch"
+)
+
+src_test() {
+ cd "${S}/test" || die
+ distutils-r1_src_test
+}