aboutsummaryrefslogtreecommitdiff
path: root/dev-python/djangorestframework-simplejwt/djangorestframework-simplejwt-5.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/djangorestframework-simplejwt/djangorestframework-simplejwt-5.3.1.ebuild')
-rw-r--r--dev-python/djangorestframework-simplejwt/djangorestframework-simplejwt-5.3.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/djangorestframework-simplejwt/djangorestframework-simplejwt-5.3.1.ebuild b/dev-python/djangorestframework-simplejwt/djangorestframework-simplejwt-5.3.1.ebuild
deleted file mode 100644
index 7ef6c72..0000000
--- a/dev-python/djangorestframework-simplejwt/djangorestframework-simplejwt-5.3.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="JSON Web Token authentication plugin for the Django REST Framework"
-HOMEPAGE="
- https://github.com/jazzband/djangorestframework-simplejwt
- https://pypi.org/project/djangorestframework-simplejwt/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/twine[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/python-jose[${PYTHON_USEDEP}]
-
- doc? ( dev-python/sphinx-rtd-theme )
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}"
-
-EPYTEST_DESELECT=(
- tests/test_utils.py::TestAwareUtcnow::test_it_should_return_the_correct_value
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs