aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-bootstrap4/django-bootstrap4-24.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-bootstrap4/django-bootstrap4-24.3.ebuild')
-rw-r--r--dev-python/django-bootstrap4/django-bootstrap4-24.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/django-bootstrap4/django-bootstrap4-24.3.ebuild b/dev-python/django-bootstrap4/django-bootstrap4-24.3.ebuild
new file mode 100644
index 0000000..0e096f4
--- /dev/null
+++ b/dev-python/django-bootstrap4/django-bootstrap4-24.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMLALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Bootstrap 4 integration with Django"
+HOMEPAGE="
+ https://github.com/zostera/django-bootstrap4
+ https://pypi.org/project/django-bootstrap4/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+# Can't run django tests
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests setup.py