aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-allauth/django-allauth-0.63.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-allauth/django-allauth-0.63.2.ebuild')
-rw-r--r--dev-python/django-allauth/django-allauth-0.63.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/django-allauth/django-allauth-0.63.2.ebuild b/dev-python/django-allauth/django-allauth-0.63.2.ebuild
new file mode 100644
index 0000000..b301cf1
--- /dev/null
+++ b/dev-python/django-allauth/django-allauth-0.63.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django applications addressing authentication, registration, account management"
+HOMEPAGE="
+ https://allauth.org/
+ https://github.com/pennersr/django-allauth
+ https://pypi.org/project/django-allauth/
+"
+SRC_URI="https://github.com/pennersr/django-allauth/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+ >=dev-python/qrcode-7.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python3-openid-3.0.8[${PYTHON_USEDEP}]
+ >=dev-python/python3-saml-1.15.0[${PYTHON_USEDEP}]
+ <dev-python/python3-saml-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.3.0[${PYTHON_USEDEP}]
+
+ test? (
+ >=dev-python/pillow-9.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-django-4.5.2[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Deselect network tests
+ allauth/socialaccount/providers/openid/tests.py::OpenIDTests::test_login
+ allauth/socialaccount/providers/openid/tests.py::OpenIDTests::test_login_with_extra_attributes
+)