aboutsummaryrefslogtreecommitdiff
path: root/dev-python/coveralls/coveralls-3.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/coveralls/coveralls-3.3.1.ebuild')
-rw-r--r--dev-python/coveralls/coveralls-3.3.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/coveralls/coveralls-3.3.1.ebuild b/dev-python/coveralls/coveralls-3.3.1.ebuild
new file mode 100644
index 0000000..4e24f20
--- /dev/null
+++ b/dev-python/coveralls/coveralls-3.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Show coverage stats online via coveralls.io"
+HOMEPAGE="https://github.com/TheKevJames/coveralls-python"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/coverage-7[${PYTHON_USEDEP}]
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"