aboutsummaryrefslogtreecommitdiff
path: root/dev-libs/restinio/restinio-0.6.17.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/restinio/restinio-0.6.17.ebuild')
-rw-r--r--dev-libs/restinio/restinio-0.6.17.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/restinio/restinio-0.6.17.ebuild b/dev-libs/restinio/restinio-0.6.17.ebuild
new file mode 100644
index 0000000..93a0286
--- /dev/null
+++ b/dev-libs/restinio/restinio-0.6.17.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Asynchronous HTTP/WebSocket server C++14 library"
+HOMEPAGE="https://github.com/Stiffstream/restinio"
+SRC_URI="https://github.com/Stiffstream/${PN}/archive/v.${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-v.${PV}/dev"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# RESTinio is not compatible with catch2-v3
+# https://github.com/Stiffstream/restinio/issues/158
+RDEPEND="
+ dev-cpp/asio
+ <=dev-cpp/catch-3
+ dev-libs/boost
+ dev-libs/libfmt
+ dev-libs/libpcre
+ dev-libs/libpcre2
+ dev-libs/openssl
+ net-libs/http-parser
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DRESTINIO_BENCH=OFF"
+ "-DRESTINIO_FIND_DEPS=ON"
+ "-DRESTINIO_SAMPLE=OFF"
+ "-DRESTINIO_TEST=$(usex test ON OFF)"
+ "-DRESTINIO_USE_EXTERNAL_HTTP_PARSER=ON"
+ "-DRESTINIO_USE_EXTERNAL_SOBJECTIZER=ON"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # Some tests open a socket on port 8085
+ # Running these tests in parallel will cause
+ # failures since the port is already in use
+ cmake_src_test -j 1
+}