aboutsummaryrefslogtreecommitdiff
path: root/dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild')
-rw-r--r--dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild b/dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild
new file mode 100644
index 0000000..1b12b0c
--- /dev/null
+++ b/dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol extensions for Hyprland"
+HOMEPAGE="https://github.com/hyprwm/hyprland-protocols"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hyprwm/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+RESTRICT=""
+
+DEPEND=""
+RDEPEND=""
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"