aboutsummaryrefslogtreecommitdiff
path: root/www-apps/searx/searx-1.0.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2022-04-20 22:28:14 -0400
committerJulien Roy <julien@jroy.ca>2022-04-20 22:28:14 -0400
commitb8fdaec72ace79fbdf3527498394445e86000cd7 (patch)
tree3bac8c17b876e97c492c848d183bb11e98d7f813 /www-apps/searx/searx-1.0.0.ebuild
parent5ad9fb8f04d9294fdfad05021ffb828db113a6ce (diff)
downloadMrRoy-Overlay-b8fdaec72ace79fbdf3527498394445e86000cd7.tar.gz
MrRoy-Overlay-b8fdaec72ace79fbdf3527498394445e86000cd7.tar.bz2
MrRoy-Overlay-b8fdaec72ace79fbdf3527498394445e86000cd7.zip
WIP: searx/invidious
Diffstat (limited to 'www-apps/searx/searx-1.0.0.ebuild')
-rw-r--r--www-apps/searx/searx-1.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/www-apps/searx/searx-1.0.0.ebuild b/www-apps/searx/searx-1.0.0.ebuild
new file mode 100644
index 0000000..d4acbb8
--- /dev/null
+++ b/www-apps/searx/searx-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Privacy-respecting metasearch engine"
+HOMEPAGE="https://searx.github.io/searx/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/searx/${PN}.git"
+else
+ SRC_URI="https://github.com/searx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="acct-user/searx
+ dev-python/pip
+ dev-python/lxml
+ dev-python/Babel
+ dev-libs/libffi
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-util/shellcheck
+ sys-libs/zlib
+ www-servers/uwsgi[python]"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install(){
+
+}