aboutsummaryrefslogtreecommitdiff
path: root/www-apps/meta-srht
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-03 20:09:57 -0500
committerJulien Roy <julien@jroy.ca>2023-01-03 20:09:57 -0500
commitb20c03f656bdb116036412f8ced539c318fc5df1 (patch)
tree7361d881e7b444e36fdd9f14199ff51f4e06eca9 /www-apps/meta-srht
parent42002f2d260994f1a6d231436ae3e3ce69f6053f (diff)
downloadMrRoy-Overlay-b20c03f656bdb116036412f8ced539c318fc5df1.tar.gz
MrRoy-Overlay-b20c03f656bdb116036412f8ced539c318fc5df1.tar.bz2
MrRoy-Overlay-b20c03f656bdb116036412f8ced539c318fc5df1.zip
www-apps/meta-srht: add initd and confd scripts
Diffstat (limited to 'www-apps/meta-srht')
-rw-r--r--www-apps/meta-srht/files/meta.sr.ht.confd2
-rw-r--r--www-apps/meta-srht/files/meta.sr.ht.initd15
-rw-r--r--www-apps/meta-srht/files/sysusers.conf1
-rw-r--r--www-apps/meta-srht/meta-srht-0.63.5.ebuild2
4 files changed, 18 insertions, 2 deletions
diff --git a/www-apps/meta-srht/files/meta.sr.ht.confd b/www-apps/meta-srht/files/meta.sr.ht.confd
new file mode 100644
index 0000000..ee7bca8
--- /dev/null
+++ b/www-apps/meta-srht/files/meta.sr.ht.confd
@@ -0,0 +1,2 @@
+BINDADDRESS=10.0.0.0
+PORT=8000 \ No newline at end of file
diff --git a/www-apps/meta-srht/files/meta.sr.ht.initd b/www-apps/meta-srht/files/meta.sr.ht.initd
new file mode 100644
index 0000000..b7a3e72
--- /dev/null
+++ b/www-apps/meta-srht/files/meta.sr.ht.initd
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="meta.sr.ht daemon"
+description=""
+command="/usr/bin/gunicorn"
+command_args="metasrht.app:app -b 127.0.0.1:5000"
+command_user="srht:srht"
+command_background=true
+pidfile="/run/${RC_SVCNAME}.pid"
+
+depend() {
+ need net
+}
diff --git a/www-apps/meta-srht/files/sysusers.conf b/www-apps/meta-srht/files/sysusers.conf
deleted file mode 100644
index 3114aec..0000000
--- a/www-apps/meta-srht/files/sysusers.conf
+++ /dev/null
@@ -1 +0,0 @@
-u metasrht - "meta.sr.ht user"
diff --git a/www-apps/meta-srht/meta-srht-0.63.5.ebuild b/www-apps/meta-srht/meta-srht-0.63.5.ebuild
index ac06d8b..7cc9b0d 100644
--- a/www-apps/meta-srht/meta-srht-0.63.5.ebuild
+++ b/www-apps/meta-srht/meta-srht-0.63.5.ebuild
@@ -21,9 +21,9 @@ RDEPEND=""
DEPEND="${RDEPEND}
acct-user/srht
acct-group/srht
- dev-db/redis
dev-python/dnspython[${PYTHON_USEDEP}]
dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
dev-python/scmsrht[${PYTHON_USEDEP}]
dev-python/qrcode[${PYTHON_USEDEP}]
dev-python/redis-py[${PYTHON_USEDEP}]