aboutsummaryrefslogtreecommitdiff
path: root/net-misc/xmrig-mo/xmrig-mo-6.16.4.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2022-03-26 21:42:48 -0400
committerJulien Roy <julien@jroy.ca>2022-03-26 21:42:48 -0400
commit9a9daa32818a5088d24c0b0ef6371968b5dba072 (patch)
treee3ef6501cc8400da6db86ed712ffcf1d8fa7ec57 /net-misc/xmrig-mo/xmrig-mo-6.16.4.ebuild
parentb23fb651ce27625be71f5dfc2e15178895734c33 (diff)
downloadMrRoy-Overlay-9a9daa32818a5088d24c0b0ef6371968b5dba072.tar.gz
MrRoy-Overlay-9a9daa32818a5088d24c0b0ef6371968b5dba072.tar.bz2
MrRoy-Overlay-9a9daa32818a5088d24c0b0ef6371968b5dba072.zip
Removed xmrig-mo since it is in Guru
Diffstat (limited to 'net-misc/xmrig-mo/xmrig-mo-6.16.4.ebuild')
-rw-r--r--net-misc/xmrig-mo/xmrig-mo-6.16.4.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/net-misc/xmrig-mo/xmrig-mo-6.16.4.ebuild b/net-misc/xmrig-mo/xmrig-mo-6.16.4.ebuild
deleted file mode 100644
index 5ec6d12..0000000
--- a/net-misc/xmrig-mo/xmrig-mo-6.16.4.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-MO_PV="mo1"
-DESCRIPTION="RandomX, CryptoNight, KawPow, AstroBWT and Argon2 miner for the MoneroOcean pool"
-HOMEPAGE="https://xmrig.com https://moneroocean.stream/ https://github.com/MoneroOcean/xmrig"
-SRC_URI="https://github.com/MoneroOcean/xmrig/archive/v${PV}-${MO_PV}.tar.gz -> ${P}-${MO_PV}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="cuda donate opencl +ssl"
-
-DEPEND="
- dev-libs/libuv:=
- sys-apps/hwloc:=
- ssl? ( dev-libs/openssl:= )
-"
-
-S="${WORKDIR}/xmrig-${PV}-${MO_PV}"
-
-#PATCHES=("${FILESDIR}/${PN}-nonotls.patch")
-
-src_prepare() {
- #use donate || PATCHES+=("${FILESDIR}/${PN}-no-default-donate.patch")
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- # TODO: Create expanded USE flag for all of the PoW algos.
-
- -DWITH_TLS=$(usex ssl)
- -DWITH_OPENCL=$(usex opencl)
- -DWITH_CUDA=$(usex cuda)
- )
-
- cmake_src_configure
-}
-
-src_install() {
- newbin "${BUILD_DIR}/xmrig" "xmrig-mo"
-}
-
-pkg_postinst() {
- einfo "Install sys-apps/msr-tools and load the msr kernel module so that"
- einfo "XMRig can perform CPU specific tweaks like disabling the instruction"
- einfo "prefetcher. Also remember to increase the vm.nr_hugepages sysctl"
- einfo "value so that XMRig can allocate with huge pages."
- einfo ""
- einfo "XMRig-MoneroOcean has been installed as /usr/bin/xmrig-mo"
- einfo "in order to differentiate between the original XMRig"
-}