aboutsummaryrefslogtreecommitdiff
path: root/net-im/mautrix-facebook/mautrix-facebook-0.4.1.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-21 20:17:36 -0500
committerJulien Roy <julien@jroy.ca>2023-01-21 20:17:36 -0500
commita24520a9a52fbd19f7148e1c4d85343b39baa220 (patch)
treeba90ae17a5d057333b91fd0e491320760f68dce3 /net-im/mautrix-facebook/mautrix-facebook-0.4.1.ebuild
parent7362b9d3a6178d7a740580b560cf8370b4907814 (diff)
downloadMrRoy-Overlay-a24520a9a52fbd19f7148e1c4d85343b39baa220.tar.gz
MrRoy-Overlay-a24520a9a52fbd19f7148e1c4d85343b39baa220.tar.bz2
MrRoy-Overlay-a24520a9a52fbd19f7148e1c4d85343b39baa220.zip
net-im/mautrix-*: update postinst, config
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'net-im/mautrix-facebook/mautrix-facebook-0.4.1.ebuild')
-rw-r--r--net-im/mautrix-facebook/mautrix-facebook-0.4.1.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/net-im/mautrix-facebook/mautrix-facebook-0.4.1.ebuild b/net-im/mautrix-facebook/mautrix-facebook-0.4.1.ebuild
index 01fac40..2a7c8c8 100644
--- a/net-im/mautrix-facebook/mautrix-facebook-0.4.1.ebuild
+++ b/net-im/mautrix-facebook/mautrix-facebook-0.4.1.ebuild
@@ -55,18 +55,22 @@ src_install() {
}
pkg_postinst() {
+ optfeature "Prometheus statistics" dev-python/prometheus_client
+ optfeature "Sqlite backend" dev-python/aiosqlite
+
einfo
- elog "Before you can use ${PN}, you must configure it correctly."
+ elog ""
+ elog "Before you can use ${PN}, you must configure it correctly"
elog "The configuration file is located at \"/etc/mautrix/${PN/-/_}.yaml\""
- elog "Next, you must generate a registration file using the following command"
- elog "sudo -u ${PN} /usr/bin/python -m ${PN/-/_} -c /etc/mautrix/${PN}.yaml g"
- elog "Next, you must register you registration.yaml file with your homeserver"
- elog "Then you must launch ${PN} by specifying the registration file"
- elog "sudo -u ${PN} /usr/bin/python -m ${PN/-/_} -r registration.yaml"
- elog "After this you can register the bridge with your homeserver"
- elog "Finally, you can start the ${PN} daemon"
+ elog "When done, run the following command: emerge --config ${PN}"
+ elog "Then, you must register the bridge with your homeserver"
+ elog "Refer to your homeserver's documentation for instructions"
+ elog "The registration file is located at /var/lib/${PN/-/\/}/registration.yaml"
+ elog "Finally, you may start the ${PN} daemon"
einfo
+}
- optfeature "Prometheus statistics" dev-python/prometheus_client
- optfeature "Sqlite backend" dev-python/aiosqlite
+pkg_config() {
+ su - "${PN}" -s /bin/sh -c \
+ "/usr/bin/python -m \"${PN/-/_}\" -c \"/etc/mautrix/${PN}.yaml -g /var/lib/${PN/-/\/}/registration.yaml\""
}