aboutsummaryrefslogtreecommitdiff
path: root/net-im/heisenbridge/heisenbridge-1.14.1.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-21 19:25:30 -0500
committerJulien Roy <julien@jroy.ca>2023-01-21 19:25:30 -0500
commit23cb9a450ffd4d72c066e76e52b31051237639c8 (patch)
tree8028e59dd2966316768beba00ddc2279873f2c33 /net-im/heisenbridge/heisenbridge-1.14.1.ebuild
parent1ca0eb5d74e279656bb7d46407a5d6d520f1c0e7 (diff)
downloadMrRoy-Overlay-23cb9a450ffd4d72c066e76e52b31051237639c8.tar.gz
MrRoy-Overlay-23cb9a450ffd4d72c066e76e52b31051237639c8.tar.bz2
MrRoy-Overlay-23cb9a450ffd4d72c066e76e52b31051237639c8.zip
net-im/heisenbridge: update post_inst
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'net-im/heisenbridge/heisenbridge-1.14.1.ebuild')
-rw-r--r--net-im/heisenbridge/heisenbridge-1.14.1.ebuild20
1 files changed, 19 insertions, 1 deletions
diff --git a/net-im/heisenbridge/heisenbridge-1.14.1.ebuild b/net-im/heisenbridge/heisenbridge-1.14.1.ebuild
index 7620f28..bb9f595 100644
--- a/net-im/heisenbridge/heisenbridge-1.14.1.ebuild
+++ b/net-im/heisenbridge/heisenbridge-1.14.1.ebuild
@@ -31,6 +31,8 @@ PATCHES=(
"${FILESDIR}/heisenbridge-1.14.1-qanotice.patch"
)
+distutils_enable_tests pytest
+
src_install() {
distutils-r1_src_install
@@ -39,4 +41,20 @@ src_install() {
systemd_dounit "${FILESDIR}/${PN}.service"
}
-distutils_enable_tests pytest
+pkg_postinst() {
+ einfo
+ elog "Before you can use ${PN}, you must configure it correctly"
+ elog "The configuration file is located at \"/etc/conf.d/${PN}"
+ elog "Then, you must generate the registration file using the following command"
+ elog "If you are using synapse:"
+ elog "/usr/bin/python -m ${PN} -c /var/lib/${PN}/registration.yaml --generate https://example.com"
+ elog "If you are using Dendrite, Conduit or others:"
+ elog "/usr/bin/python -m ${PN} -c /var/lib/${PN}/registration.yaml --generate-compat https://example.com"
+ elog "Notice the URL at the end, replace it with your homeserver's URL"
+ elog "Then, you must register the bridge with your homeserver"
+ elog "Refer to your homeserver's documentation for instruction"
+ elog "The registration file is located at /var/lib/${PN}/registration.yaml"
+ elog "Finally, you may start the ${PN} daemon"
+ einfo
+
+}