aboutsummaryrefslogtreecommitdiff
path: root/net-im/heisenbridge/heisenbridge-1.14.1.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-22 22:57:51 -0500
committerJulien Roy <julien@jroy.ca>2023-01-22 22:57:51 -0500
commit1e3e2506203331b90aa1ccbdf571c27b7ef3ad14 (patch)
tree3f3a6fb21cd9639446bfe383333b95eb983fcb2f /net-im/heisenbridge/heisenbridge-1.14.1.ebuild
parentce7da04d2c2fb7de10f862fd60c97f6809a0f9ef (diff)
downloadMrRoy-Overlay-1e3e2506203331b90aa1ccbdf571c27b7ef3ad14.tar.gz
MrRoy-Overlay-1e3e2506203331b90aa1ccbdf571c27b7ef3ad14.tar.bz2
MrRoy-Overlay-1e3e2506203331b90aa1ccbdf571c27b7ef3ad14.zip
*/*: treeclean packages which are now in GURU
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'net-im/heisenbridge/heisenbridge-1.14.1.ebuild')
-rw-r--r--net-im/heisenbridge/heisenbridge-1.14.1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/net-im/heisenbridge/heisenbridge-1.14.1.ebuild b/net-im/heisenbridge/heisenbridge-1.14.1.ebuild
deleted file mode 100644
index cc4a9a2..0000000
--- a/net-im/heisenbridge/heisenbridge-1.14.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 systemd
-
-DESCRIPTION="A bouncer-style Matrix IRC bridge"
-HOMEPAGE="https://github.com/hifi/heisenbridge/"
-SRC_URI="https://github.com/hifi/heisenbridge/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- acct-user/${PN}
- dev-python/irc[${PYTHON_USEDEP}]
- dev-python/mautrix[${PYTHON_USEDEP}]
- dev-python/python-socks[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/heisenbridge-1.14.1-qanotice.patch"
-)
-
-distutils_enable_tests pytest
-
-src_install() {
- distutils-r1_src_install
-
- newinitd "${FILESDIR}/heisenbridge.initd" "${PN}"
- newconfd "${FILESDIR}/heisenbridge.confd" "${PN}"
- systemd_dounit "${FILESDIR}/${PN}.service"
-}
-
-pkg_postinst() {
- einfo
- elog "Before you can use ${PN}, you must configure it correctly"
- elog "The configuration file is located at /etc/conf.d/${PN}"
- elog "Then, you must generate the registration file using the following command"
- elog "If you are using synapse:"
- elog "/usr/bin/python -m ${PN} -c /var/lib/${PN}/registration.yaml --generate https://example.com"
- elog "If you are using Dendrite, Conduit or others:"
- elog "/usr/bin/python -m ${PN} -c /var/lib/${PN}/registration.yaml --generate-compat https://example.com"
- elog "Notice the URL at the end, replace it with your homeserver's URL"
- elog "Then, you must register the bridge with your homeserver"
- elog "Refer to your homeserver's documentation for instructions"
- elog "The registration file is located at /var/lib/${PN}/registration.yaml"
- elog "Finally, you may start the ${PN} daemon"
- einfo
-
-}