aboutsummaryrefslogtreecommitdiff
path: root/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-02 15:56:55 -0500
committerJulien Roy <julien@jroy.ca>2023-01-02 15:56:55 -0500
commitba8fab5645ea781e5f77abd6cbfe68e045692dc1 (patch)
tree4eddf720e3867a0c87c691d52e75832865c09bcd /gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
parent17a573902f2cfc84476b22d943dd10b2248f7b86 (diff)
downloadMrRoy-Overlay-ba8fab5645ea781e5f77abd6cbfe68e045692dc1.tar.gz
MrRoy-Overlay-ba8fab5645ea781e5f77abd6cbfe68e045692dc1.tar.bz2
MrRoy-Overlay-ba8fab5645ea781e5f77abd6cbfe68e045692dc1.zip
*/*: Remove packages now in guru
Signed off by: Julien Roy <julien.roy@jroy.ca>
Diffstat (limited to 'gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild')
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
deleted file mode 100644
index 2667dcd..0000000
--- a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="xdg-desktop-portal backend for hyprland"
-HOMEPAGE="https://github.com/hyprwm/xdg-desktop-portal-hyprland"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/hyprwm/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/hyprwm/${PN}/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="elogind systemd"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
- >=media-video/pipewire-0.3.41:=
- dev-libs/inih
- dev-libs/wayland
- media-libs/mesa
- x11-libs/libdrm
- || (
- systemd? ( >=sys-apps/systemd-237 )
- elogind? ( >=sys-auth/elogind-237 )
- sys-libs/basu
- )
- dev-qt/qtbase
- dev-qt/qtwayland:6
-"
-# mesa is needed for gbm dep (which it hards sets to 'on')
-RDEPEND="
- ${DEPEND}
- sys-apps/xdg-desktop-portal
-"
-BDEPEND="
- >=dev-libs/wayland-protocols-1.24
- virtual/pkgconfig
-"
-
-src_configure() {
- local emesonargs=()
-
- if use systemd; then
- emesonargs+=(-Dsd-bus-provider=libsystemd)
- elif use elogind; then
- emesonargs+=(-Dsd-bus-provider=libelogind)
- else
- emesonargs+=(-Dsd-bus-provider=basu)
- fi
- meson_src_configure
-}
-
-MAKEOPTS="-C ${S}/hyprland-share-picker"
-src_compile() {
- meson_src_compile
- emake all
-}
-
-src_install() {
- meson_src_install
- dobin "${S}/hyprland-share-picker/build/hyprland-share-picker"
-}