aboutsummaryrefslogtreecommitdiff
path: root/dev-vcs/git-srht/git-srht-0.81.3.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-05 20:03:45 -0500
committerJulien Roy <julien@jroy.ca>2023-01-05 20:03:45 -0500
commita32792ac685c17544d1507fdc3ce1b202cc28f8a (patch)
treedaba08d97f6bf67d35491c987a4e038614a61c95 /dev-vcs/git-srht/git-srht-0.81.3.ebuild
parentb4c9c49d3b615dd2a08c3fc81621e28ecc8214c3 (diff)
downloadMrRoy-Overlay-a32792ac685c17544d1507fdc3ce1b202cc28f8a.tar.gz
MrRoy-Overlay-a32792ac685c17544d1507fdc3ce1b202cc28f8a.tar.bz2
MrRoy-Overlay-a32792ac685c17544d1507fdc3ce1b202cc28f8a.zip
dev-vcs/git-srht: new package, add 0.81.3
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-vcs/git-srht/git-srht-0.81.3.ebuild')
-rw-r--r--dev-vcs/git-srht/git-srht-0.81.3.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-vcs/git-srht/git-srht-0.81.3.ebuild b/dev-vcs/git-srht/git-srht-0.81.3.ebuild
new file mode 100644
index 0000000..1d01f26
--- /dev/null
+++ b/dev-vcs/git-srht/git-srht-0.81.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 go-module optfeature systemd
+
+DESCRIPTION="sr.ht git services"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/git.sr.ht"
+SRC_URI="http://git.sr.ht/~sircmpwn/git.sr.ht/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/scmsrht[${PYTHON_USEDEP}]
+ dev-python/core-srht[${PYTHON_USEDEP}]
+ dev-python/pygit2[${PYTHON_USEDEP}]
+ dev-python/minio[${PYTHON_USEDEP}]
+"
+BDEPEND="net-libs/nodejs
+ dev-lang/sassc
+ dev-lang/go
+"
+
+S="${WORKDIR}/git.sr.ht-${PV}"
+
+src_unpack() {
+ default_src_unpack
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ cd "${S}/gitsrht-dispatch" || die
+ ego build
+ cd "${S}/gitsrht-shell" || die
+ ego build
+ cd "${S}/gitsrht-keys" || die
+ ego build
+ cd "${S}/gitsrht-update-hook" || die
+ ego build
+ cd "${S}/api" || die
+ ego build -o gitsrht-api
+}
+
+src_install() {
+ distutils-r1_src_install
+ dobin "${S}/gitsrht-dispatch/gitsrht-dispatch"
+ dobin "${S}/gitsrht-shell/gitsrht-shell"
+ dobin "${S}/gitsrht-keys/gitsrht-keys"
+ dobin "${S}/gitsrht-update-hook/gitsrht-update-hook"
+ dobin "${S}/api/gitsrht-api"
+ exeinto "/etc/cron.hourly"
+ doexe "${FILESDIR}/git.sr.ht.cron"
+ newinitd "${FILESDIR}/git.sr.ht.initd" "git.sr.ht"
+ newconfd "${FILESDIR}/git.sr.ht.confd" "git.sr.ht"
+ newinitd "${FILESDIR}/git.sr.ht-api.initd" "git.sr.ht-api"
+ newconfd "${FILESDIR}/git.sr.ht-api.confd" "git.sr.ht-api"
+ newinitd "${FILESDIR}/git.sr.ht-webhooks.initd" "git.sr.ht-webhooks"
+ systemd_dounit "${FILESDIR}/git.sr.ht.service"
+ systemd_dounit "${FILESDIR}/git.sr.ht-api.service"
+ systemd_dounit "${FILESDIR}/git.sr.ht-webhooks.service"
+ systemd_dounit "${FILESDIR}/git.sr.ht-periodic.service"
+ systemd_dounit "${FILESDIR}/git.sr.ht-periodic.timer"
+}
+
+plg_postinst() {
+ optfeature "builds.sr.ht integration" "dev-util/builds-srht"
+}