aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-testrunner/zope-testrunner-6.2.1.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-01-03 21:11:20 -0500
committerJulien Roy <julien@jroy.ca>2024-01-03 21:11:20 -0500
commitc35f4a6a1b23066eb29131628b0d6e758794eeae (patch)
tree7f33ad08b1780f102756d09e6e5b8dccd72c0bff /dev-python/zope-testrunner/zope-testrunner-6.2.1.ebuild
parentfaada8d9a4c584f77e7a212b42c6845378d4b85a (diff)
downloadMrRoy-Overlay-c35f4a6a1b23066eb29131628b0d6e758794eeae.tar.gz
MrRoy-Overlay-c35f4a6a1b23066eb29131628b0d6e758794eeae.tar.bz2
MrRoy-Overlay-c35f4a6a1b23066eb29131628b0d6e758794eeae.zip
WIP
Diffstat (limited to 'dev-python/zope-testrunner/zope-testrunner-6.2.1.ebuild')
-rw-r--r--dev-python/zope-testrunner/zope-testrunner-6.2.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/zope-testrunner/zope-testrunner-6.2.1.ebuild b/dev-python/zope-testrunner/zope-testrunner-6.2.1.ebuild
new file mode 100644
index 0000000..ca4c95c
--- /dev/null
+++ b/dev-python/zope-testrunner/zope-testrunner-6.2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+PYPI_NO_NORMALIZE=1
+PYPI_PN="${PN/-/\.}"
+inherit distutils-r1 pypi
+
+DESCRIPTION="This package provides a flexible test runner with layer support."
+HOMEPAGE="https://github.com/zopefoundation/zope.testrunner
+ https://pypi.org/project/zope.testrunner/
+"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/zope-exceptions[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinxcontrib-programoutput[${PYTHON_USEDEP}] )
+ test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ distutils_write_namespace zope
+ eunittest
+}
+
+python_install() {
+ # Do not install unit tests
+ rm -r "${BUILD_DIR}/install$(python_get_sitedir)/zope/testrunner/tests" || die
+ distutils-r1_python_install
+}