aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-site/zope-site-4.6.1.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-02-06 23:14:47 -0500
committerJulien Roy <julien@jroy.ca>2023-02-06 23:14:47 -0500
commit4cbb224d9e27d302a9cf9129b573313407f7e641 (patch)
tree9fae321b5941e8ab6b06e4f2539f1b7f2d8ef1c1 /dev-python/zope-site/zope-site-4.6.1.ebuild
parentd0c416569de0fc3007369ae191ff4bee2d18062c (diff)
downloadMrRoy-Overlay-4cbb224d9e27d302a9cf9129b573313407f7e641.tar.gz
MrRoy-Overlay-4cbb224d9e27d302a9cf9129b573313407f7e641.tar.bz2
MrRoy-Overlay-4cbb224d9e27d302a9cf9129b573313407f7e641.zip
dev-python/zope-site: new package, add 4.6.1
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/zope-site/zope-site-4.6.1.ebuild')
-rw-r--r--dev-python/zope-site/zope-site-4.6.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/zope-site/zope-site-4.6.1.ebuild b/dev-python/zope-site/zope-site-4.6.1.ebuild
new file mode 100644
index 0000000..3a388a5
--- /dev/null
+++ b/dev-python/zope-site/zope-site-4.6.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Local registries for zope component architecture"
+HOMEPAGE="https://github.com/zopefoundation/zope.site"
+SRC_URI="https://github.com/zopefoundation/zope.site/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN/-/\.}-${PV}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+# Zope Testrunner
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/zope-annotation[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-container[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ dev-python/zope-deprecation[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/zope-lifecycleevent[${PYTHON_USEDEP}]
+ dev-python/zope-location[${PYTHON_USEDEP}]
+ dev-python/zope-security[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/repoze-sphinx-autointerface[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/zodb[${PYTHON_USEDEP}]
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ dev-python/zope-testrunner[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_test() {
+ cd "${S}/src/zope/untrustedpython" || die
+ distutils-r1_src_test
+}