aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-security/zope-security-6.1.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-02-04 23:32:27 -0500
committerJulien Roy <julien@jroy.ca>2023-02-04 23:32:27 -0500
commit8ef8c060ef0b4c7ebf72eac536adfdf204306c4e (patch)
treeb784df5ba7342df2b10f693a9454c2ae5013f3cf /dev-python/zope-security/zope-security-6.1.ebuild
parent38a35afc9d1001654bf05c02e302581ce863ba12 (diff)
downloadMrRoy-Overlay-8ef8c060ef0b4c7ebf72eac536adfdf204306c4e.tar.gz
MrRoy-Overlay-8ef8c060ef0b4c7ebf72eac536adfdf204306c4e.tar.bz2
MrRoy-Overlay-8ef8c060ef0b4c7ebf72eac536adfdf204306c4e.zip
dev-python/zope-security: new package, add 6.1
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/zope-security/zope-security-6.1.ebuild')
-rw-r--r--dev-python/zope-security/zope-security-6.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/zope-security/zope-security-6.1.ebuild b/dev-python/zope-security/zope-security-6.1.ebuild
new file mode 100644
index 0000000..bb1b5c9
--- /dev/null
+++ b/dev-python/zope-security/zope-security-6.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python descriptors which cache their output"
+HOMEPAGE="https://github.com/zopefoundation/zope.security"
+SRC_URI="https://github.com/zopefoundation/zope.security/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN/-/\.}-${PV}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+# Tests fail, needs to be investigate
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/zope-location[${PYTHON_USEDEP}]
+ dev-python/zope-proxy[${PYTHON_USEDEP}]
+ dev-python/zope-schema[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/repoze-sphinx-autointerface[${PYTHON_USEDEP}]
+ dev-python/zope-configuration[${PYTHON_USEDEP}]
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/btrees[${PYTHON_USEDEP}]
+ dev-python/zope-configuration[${PYTHON_USEDEP}]
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ dev-python/zope-testrunner[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_test() {
+ cd "${S}/src/zope/security" || die
+ distutils-r1_src_test
+}