aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-lifecycleevent/zope-lifecycleevent-4.4.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-02-04 22:00:14 -0500
committerJulien Roy <julien@jroy.ca>2023-02-04 22:00:14 -0500
commit9e7e232bf03bbb1eae0d03742bd121f64e986667 (patch)
tree395298f8581ff409042422e786741cf1968b02d4 /dev-python/zope-lifecycleevent/zope-lifecycleevent-4.4.ebuild
parent631a280c2b2a79905facf113d50a7a24f57d7dfd (diff)
downloadMrRoy-Overlay-9e7e232bf03bbb1eae0d03742bd121f64e986667.tar.gz
MrRoy-Overlay-9e7e232bf03bbb1eae0d03742bd121f64e986667.tar.bz2
MrRoy-Overlay-9e7e232bf03bbb1eae0d03742bd121f64e986667.zip
dev-python/zope-lifecycleevent: new package, add 4.4
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/zope-lifecycleevent/zope-lifecycleevent-4.4.ebuild')
-rw-r--r--dev-python/zope-lifecycleevent/zope-lifecycleevent-4.4.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/zope-lifecycleevent/zope-lifecycleevent-4.4.ebuild b/dev-python/zope-lifecycleevent/zope-lifecycleevent-4.4.ebuild
new file mode 100644
index 0000000..dd3a9b1
--- /dev/null
+++ b/dev-python/zope-lifecycleevent/zope-lifecycleevent-4.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Events for creation, modification of objects"
+HOMEPAGE="https://github.com/zopefoundation/zope.lifecycleevent"
+SRC_URI="https://github.com/zopefoundation/zope.lifecycleevent/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN/-/\.}-${PV}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/repoze-sphinx-autointerface[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-configuration[${PYTHON_USEDEP}]
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ dev-python/zope-testrunner[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_test() {
+ cd "${S}/src/zope/lifecycleevent" || die
+ distutils-r1_src_test
+}