aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-dublincore/zope-dublincore-4.3.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-02-06 22:38:07 -0500
committerJulien Roy <julien@jroy.ca>2023-02-06 22:38:07 -0500
commit53e3f4cabd4eb79973e29d17679cb62da9685f86 (patch)
tree92c96a204c462a959d54cb2b6391db670235f5a4 /dev-python/zope-dublincore/zope-dublincore-4.3.0.ebuild
parentcfd164e212c7f9f5eee00c67107e2c0d28f6418e (diff)
downloadMrRoy-Overlay-53e3f4cabd4eb79973e29d17679cb62da9685f86.tar.gz
MrRoy-Overlay-53e3f4cabd4eb79973e29d17679cb62da9685f86.tar.bz2
MrRoy-Overlay-53e3f4cabd4eb79973e29d17679cb62da9685f86.zip
dev-python/zope-dublincore: new package, add 4.3.0
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/zope-dublincore/zope-dublincore-4.3.0.ebuild')
-rw-r--r--dev-python/zope-dublincore/zope-dublincore-4.3.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/zope-dublincore/zope-dublincore-4.3.0.ebuild b/dev-python/zope-dublincore/zope-dublincore-4.3.0.ebuild
new file mode 100644
index 0000000..4ec3427
--- /dev/null
+++ b/dev-python/zope-dublincore/zope-dublincore-4.3.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Zope Dublin Core implementation"
+HOMEPAGE="https://github.com/zopefoundation/zope.dublincore"
+SRC_URI="https://github.com/zopefoundation/zope.dublincore/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN/-/\.}-${PV}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+# Zope Testrunner
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/persistent[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/zope-annotation[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-datetime[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/zope-lifecycleevent[${PYTHON_USEDEP}]
+ dev-python/zope-location[${PYTHON_USEDEP}]
+ dev-python/zope-schema[${PYTHON_USEDEP}]
+ dev-python/zope-security[${PYTHON_USEDEP}]
+ doc? ( dev-python/repoze-sphinx-autointerface[${PYTHON_USEDEP}] )
+ test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_test() {
+ cd "${S}/src/zope/untrustedpython" || die
+ distutils-r1_src_test
+}