aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-cachedescriptors/zope-cachedescriptors-5.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-01-03 21:11:20 -0500
committerJulien Roy <julien@jroy.ca>2024-01-03 21:11:20 -0500
commitc35f4a6a1b23066eb29131628b0d6e758794eeae (patch)
tree7f33ad08b1780f102756d09e6e5b8dccd72c0bff /dev-python/zope-cachedescriptors/zope-cachedescriptors-5.0.ebuild
parentfaada8d9a4c584f77e7a212b42c6845378d4b85a (diff)
downloadMrRoy-Overlay-c35f4a6a1b23066eb29131628b0d6e758794eeae.tar.gz
MrRoy-Overlay-c35f4a6a1b23066eb29131628b0d6e758794eeae.tar.bz2
MrRoy-Overlay-c35f4a6a1b23066eb29131628b0d6e758794eeae.zip
WIP
Diffstat (limited to 'dev-python/zope-cachedescriptors/zope-cachedescriptors-5.0.ebuild')
-rw-r--r--dev-python/zope-cachedescriptors/zope-cachedescriptors-5.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/zope-cachedescriptors/zope-cachedescriptors-5.0.ebuild b/dev-python/zope-cachedescriptors/zope-cachedescriptors-5.0.ebuild
new file mode 100644
index 0000000..c48326b
--- /dev/null
+++ b/dev-python/zope-cachedescriptors/zope-cachedescriptors-5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+PYPI_NO_NORMALIZE=1
+PYPI_PN="${PN/-/\.}"
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python descriptors which cache their output"
+HOMEPAGE="https://github.com/zopefoundation/zope.cachedescriptors"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}