aboutsummaryrefslogtreecommitdiff
path: root/dev-python/tulir-telethon/tulir-telethon-1.27.0_alpha6.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-22 22:57:51 -0500
committerJulien Roy <julien@jroy.ca>2023-01-22 22:57:51 -0500
commit1e3e2506203331b90aa1ccbdf571c27b7ef3ad14 (patch)
tree3f3a6fb21cd9639446bfe383333b95eb983fcb2f /dev-python/tulir-telethon/tulir-telethon-1.27.0_alpha6.ebuild
parentce7da04d2c2fb7de10f862fd60c97f6809a0f9ef (diff)
downloadMrRoy-Overlay-1e3e2506203331b90aa1ccbdf571c27b7ef3ad14.tar.gz
MrRoy-Overlay-1e3e2506203331b90aa1ccbdf571c27b7ef3ad14.tar.bz2
MrRoy-Overlay-1e3e2506203331b90aa1ccbdf571c27b7ef3ad14.zip
*/*: treeclean packages which are now in GURU
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/tulir-telethon/tulir-telethon-1.27.0_alpha6.ebuild')
-rw-r--r--dev-python/tulir-telethon/tulir-telethon-1.27.0_alpha6.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/tulir-telethon/tulir-telethon-1.27.0_alpha6.ebuild b/dev-python/tulir-telethon/tulir-telethon-1.27.0_alpha6.ebuild
deleted file mode 100644
index 8f9b5e0..0000000
--- a/dev-python/tulir-telethon/tulir-telethon-1.27.0_alpha6.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-MY_PV="${PV/_alph/}"
-DESCRIPTION="Pure Python 3 MTProto API Telegram client library, for bots too!"
-HOMEPAGE="https://github.com/tulir/Telethon/"
-SRC_URI="https://github.com/tulir/Telethon/archive/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/Telethon-${MY_PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/cryptg[${PYTHON_USEDEP}]
- dev-python/hachoir[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pyaes[${PYTHON_USEDEP}]
- dev-python/PySocks[${PYTHON_USEDEP}]
- dev-python/python-socks[${PYTHON_USEDEP}]
- dev-python/rsa[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests pytest